SPADVROUTE - Multicast LAB

###################################
Enable IGMP and MLD

Cisco IOS XR:
-enable multicast routing on the interface GigabitEthernet0/0/0/0:

multicast-routing
 address-family ipv4
  interface GigabitEthernet0/0/0/0
   enable


- enable igmp on the interface Gi0/0/0/0:

router igmp
 vrf default
 !
 interface GigabitEthernet0/0/0/0
  version 3
  query-interval 60
  router enable


- enable ipv6 multicast and mld:

multicast-routing
 address-family ipv4
  interface GigabitEthernet0/0/0/0
   enable

router mld
 interface GigabitEthernet0/0/0/0
  router enable


###################################
Implement PIM-SM

Enable IP multicast routing on PE and CE routers and configure loopback0 of P1 as RP :

--cisco IOS XR - PE2 and P1:

!
multicast-routing
 address-family ipv4
  interface all enable
 !
 address-family ipv6
  interface GigabitEthernet0/0/0/0
   enable
  !
 
!
router mld
 interface GigabitEthernet0/0/0/0
  query-interval 60
  router enable
 !
!
router igmp
 vrf default
 !
 interface GigabitEthernet0/0/0/0
  version 2
  query-interval 30
  router enable
 !
!
router pim
 address-family ipv4
  rp-address 10.0.1.1
  interface Loopback0


--cisco IOS:

interface Loopback0
 ip pim sparse-mode


interface Ethernet0/0
 ip pim sparse-mode

interface Ethernet0/1
 ip pim sparse-mode


interface Ethernet0/2
 ip pim sparse-mode


interface Ethernet0/3
 ip pim sparse-mode


ip pim rp-address 10.0.1.1

 

 ### Verify:

 PE1#show ip pim interface

Address          Interface                Ver/   Nbr    Query  DR     DR
                                          Mode   Count  Intvl  Prior
192.168.101.10   Ethernet0/0              v2/S   1      30     1      192.168.101.11
192.168.11.10    Ethernet0/1              v2/S   1      30     1      192.168.11.10
192.168.112.10   Ethernet0/2              v2/S   1      30     1      192.168.112.20
10.1.1.1         Loopback0                v2/S   0      30     1      10.1.1.1
192.168.12.10    Ethernet0/3              v2/S   1      30     1      192.168.12.10
PE1#


RP/0/0/CPU0:PE2#show pim interface
Wed Jul 15 09:47:20.264 UTC

PIM interfaces in VRF default
Address               Interface                     PIM  Nbr   Hello  DR    DR
                                                         Count Intvl  Prior

10.2.1.1              Loopback0                     on   1     30     1     this system
192.168.102.20        GigabitEthernet0/0/0/0        on   2     30     1     192.168.102.21
192.168.112.20        GigabitEthernet0/0/0/1        on   2     30     1     this system
192.168.22.20         GigabitEthernet0/0/0/2        on   2     30     1     this system
192.168.21.20         GigabitEthernet0/0/0/3        on   2     30     1     this system
RP/0/0/CPU0:PE2#

CE2#show ip pim interface
Address          Interface                Ver/   Nbr    Query  DR     DR
                                          Mode   Count  Intvl  Prior
192.168.102.21   Ethernet0/0              v2/S   1      30     1      192.168.102.21
10.2.10.1        Loopback0                v2/S   0      30     1      10.2.10.1
CE2#

CE1#show ip pim interface

Address          Interface                Ver/   Nbr    Query  DR     DR
                                          Mode   Count  Intvl  Prior
192.168.101.11   Ethernet0/0              v2/S   1      30     1      192.168.101.11
10.1.10.1        Loopback0                v2/S   0      30     1      10.1.10.1
CE1#


RP/0/0/CPU0:PE2#sh pim neighbor
Wed Jul 15 10:01:22.667 UTC

PIM neighbors in VRF default
Flag: B - Bidir capable, P - Proxy capable, DR - Designated Router,
      E - ECMP Redirect capable
      * indicates the neighbor created for this router

Neighbor Address             Interface              Uptime    Expires  DR pri   Flags

192.168.102.20*              GigabitEthernet0/0/0/0 1d12h     00:01:22 1      B P E
192.168.102.21               GigabitEthernet0/0/0/0 1d12h     00:01:17 1 (DR) P
192.168.112.10               GigabitEthernet0/0/0/1 2d16h     00:01:15 1      P
192.168.112.20*              GigabitEthernet0/0/0/1 2d18h     00:01:20 1 (DR) B P E
192.168.22.2                 GigabitEthernet0/0/0/2 2d16h     00:01:31 1      P
192.168.22.20*               GigabitEthernet0/0/0/2 2d18h     00:01:23 1 (DR) B P E
192.168.21.1                 GigabitEthernet0/0/0/3 2d18h     00:01:33 1      B P
192.168.21.20*               GigabitEthernet0/0/0/3 2d18h     00:01:33 1 (DR) B P E
10.2.1.1*                    Loopback0              2d18h     00:01:36 1 (DR) B P E
RP/0/0/CPU0:PE2#

 

#######
Simulate multicast receivers for group 224.1.x.1 (or 224.1.y.1) on the Loopback0 interface on the CE and PE routers.

Throughout the lab exercise, use the ip igmp join-group command on Cisco IOS and IOSXE Software under interface configuration mode to simulate multicast receivers. On the Cisco IOS XR Software, use the join-group command under interface configuration mode under router igmp configuration mode.

CE1(config)#int lo0
CE1(config-if)#ip igmp join-group 224.1.1.1
CE1(config-if)#exit
CE1(config)#exit

PE1(config)#int lo0
PE1(config-if)#ip igmp join-gr
PE1(config-if)#ip igmp join-group 224.1.1.1
PE1(config-if)#exit
PE1(config)#exit

RP/0/0/CPU0:PE2# conf
RP/0/0/CPU0:PE2(config)#router igmp
RP/0/0/CPU0:PE2(config-igmp)#interface loopback 0
RP/0/0/CPU0:PE2(config-igmp-default-if)#join-group 224.1.2.1
RP/0/0/CPU0:PE2(config-igmp-default-if)#commi
RP/0/0/CPU0:PE2(config-igmp-default-if)#exit
RP/0/0/CPU0:PE2(config-igmp)#exit
RP/0/0/CPU0:PE2(config)#exit


CE2(config)#int lo0
CE2(config-if)#ip igmp join-gr
CE2(config-if)#ip igmp join-group 224.1.2.1
CE2(config-if)#exit
CE2(config)#exit


CE routers need to have a route to  the RP:10.0.1.1, so I configured a static route pointing to the respective PE.

CE1#show ip mroute
IP Multicast Routing Table
Flags: D - Dense, S - Sparse, B - Bidir Group, s - SSM Group, C - Connected,
       L - Local, P - Pruned, R - RP-bit set, F - Register flag,
       T - SPT-bit set, J - Join SPT, M - MSDP created entry, E - Extranet,
       X - Proxy Join Timer Running, A - Candidate for MSDP Advertisement,
       U - URD, I - Received Source Specific Host Report,
       Z - Multicast Tunnel, z - MDT-data group sender,
       Y - Joined MDT-data group, y - Sending to MDT-data group,
       G - Received BGP C-Mroute, g - Sent BGP C-Mroute,
       N - Received BGP Shared-Tree Prune, n - BGP C-Mroute suppressed,
       Q - Received BGP S-A Route, q - Sent BGP S-A Route,
       V - RD & Vector, v - Vector, p - PIM Joins on route
Outgoing interface flags: H - Hardware switched, A - Assert winner, p - PIM Join
 Timers: Uptime/Expires
 Interface state: Interface, Next-Hop or VCD, State/Mode

(*, 224.1.1.1), 00:03:26/00:02:02, RP 10.0.1.1, flags: SJCL
  Incoming interface: Ethernet0/0, RPF nbr 192.168.101.10
  Outgoing interface list:
    Loopback0, Forward/Sparse, 00:03:26/00:02:02

(*, 224.0.1.40), 2d16h/00:02:56, RP 10.0.1.1, flags: SJPCL
  Incoming interface: Ethernet0/0, RPF nbr 192.168.101.10
  Outgoing interface list: Null

CE1#


PE1:

(*, 224.1.1.1), 00:04:00/00:03:24, RP 10.0.1.1, flags: SJCL
  Incoming interface: Ethernet0/1, RPF nbr 192.168.11.1
  Outgoing interface list:
    Loopback0, Forward/Sparse, 00:03:43/00:02:02
    Ethernet0/0, Forward/Sparse, 00:04:00/00:03:24

(*, 224.0.1.40), 2d16h/00:03:03, RP 10.0.1.1, flags: SJCL
  Incoming interface: Ethernet0/1, RPF nbr 192.168.11.1
  Outgoing interface list:
    Ethernet0/0, Forward/Sparse, 1d12h/00:03:03

PE1#

 

PE2:
RP/0/0/CPU0:PE2#show mrib route
Wed Jul 15 10:07:04.333 UTC

IP Multicast Routing Information Base
Entry flags: L - Domain-Local Source, E - External Source to the Domain,
    C - Directly-Connected Check, S - Signal, IA - Inherit Accept,
    IF - Inherit From, D - Drop, ME - MDT Encap, EID - Encap ID,
    MD - MDT Decap, MT - MDT Threshold Crossed, MH - MDT interface handle
    CD - Conditional Decap, MPLS - MPLS Decap, MF - MPLS Encap, EX - Extranet
    MoFE - MoFRR Enabled, MoFS - MoFRR State, MoFP - MoFRR Primary
    MoFB - MoFRR Backup, RPFID - RPF ID Set, X - VXLAN
Interface flags: F - Forward, A - Accept, IC - Internal Copy,
    NS - Negate Signal, DP - Don't Preserve, SP - Signal Present,
    II - Internal Interest, ID - Internal Disinterest, LI - Local Interest,
    LD - Local Disinterest, DI - Decapsulation Interface
    EI - Encapsulation Interface, MI - MDT Interface, LVIF - MPLS Encap,
    EX - Extranet, A2 - Secondary Accept, MT - MDT Threshold Crossed,
    MA - Data MDT Assigned, LMI - mLDP MDT Interface, TMI - P2MP-TE MDT Interface
    IRMI - IR MDT Interface

(*,224.0.0.0/4) RPF nbr: 192.168.21.1 Flags: C RPF P
  Up: 2d18h

(*,224.0.0.0/24) Flags: D P
  Up: 1w0d

(*,224.0.1.39) Flags: S P
  Up: 1w0d

(*,224.0.1.40) Flags: S P
  Up: 1w0d
  Outgoing Interface List
    Loopback0 Flags: II LI, Up: 2d16h
    GigabitEthernet0/0/0/0 Flags: LI, Up: 1d12h

(*,224.1.2.1) RPF nbr: 192.168.21.1 Flags: C RPF
  Up: 00:03:52
  Incoming Interface List
    GigabitEthernet0/0/0/3 Flags: A NS, Up: 00:03:52
  Outgoing Interface List
    Loopback0 Flags: F IC NS II LI, Up: 00:03:02
    GigabitEthernet0/0/0/0 Flags: F NS, Up: 00:03:52

(*,232.0.0.0/8) Flags: D P
  Up: 1w0d
RP/0/0/CPU0:PE2#   

 

CE2:
(*, 224.1.2.1), 00:04:43/00:02:20, RP 10.0.1.1, flags: SJCL
  Incoming interface: Ethernet0/0, RPF nbr 192.168.102.20
  Outgoing interface list:
    Loopback0, Forward/Sparse, 00:04:43/00:02:20

(*, 224.0.1.40), 2d16h/00:02:38, RP 10.0.1.1, flags: SJPCL
  Incoming interface: Ethernet0/0, RPF nbr 192.168.102.20
  Outgoing interface list: Null

CE2#


P1:
(*,224.0.0.0/4) RPF nbr: 10.0.1.1 Flags: L C RPF P
  Up: 2d18h
  Outgoing Interface List
    Decapstunnel0 Flags: NS DI, Up: 2d18h

(*,224.0.0.0/24) Flags: D P
  Up: 2d18h

(*,224.0.1.39) Flags: S P
  Up: 2d18h

(*,224.0.1.40) Flags: S P
  Up: 2d18h
  Outgoing Interface List
    Loopback0 Flags: II LI, Up: 2d18h
    GigabitEthernet0/0/0/2 Flags: LI, Up: 2d16h

(*,224.1.1.1) RPF nbr: 10.0.1.1 Flags: C RPF
  Up: 00:06:01
  Incoming Interface List
    Decapstunnel0 Flags: A, Up: 00:06:01
  Outgoing Interface List
    GigabitEthernet0/0/0/0 Flags: F NS, Up: 00:06:01

(*,224.1.2.1) RPF nbr: 10.0.1.1 Flags: C RPF
  Up: 00:05:26
  Incoming Interface List
    Decapstunnel0 Flags: A, Up: 00:05:26
  Outgoing Interface List
    GigabitEthernet0/0/0/1 Flags: F NS, Up: 00:05:26

(*,232.0.0.0/8) Flags: D P
  Up: 2d18h
RP/0/0/CPU0:P1_RR#             

 

Start ping on CE1:
CE1#ping 224.1.2.1 source loopback 0 repeat 100

Type escape sequence to abort.
Sending 100, 100-byte ICMP Echos to 224.1.2.1, timeout is 2 seconds:
Packet sent with a source address of 10.1.10.1
.
Reply to request 1 from 10.2.1.1, 30 ms
Reply to request 1 from 10.2.10.1, 39 ms
Reply to request 1 from 10.2.10.1, 38 ms


CE1# show ip mroute
(*, 224.1.2.1), 00:00:09/stopped, RP 10.0.1.1, flags: SPF
  Incoming interface: Ethernet0/0, RPF nbr 192.168.101.10
  Outgoing interface list: Null

(10.1.10.1, 224.1.2.1), 00:00:09/00:03:25, flags: FT
  Incoming interface: Loopback0, RPF nbr 0.0.0.0
  Outgoing interface list:
    Ethernet0/0, Forward/Sparse, 00:00:09/00:03:20, A

(*, 224.1.1.1), 02:26:30/00:02:00, RP 10.0.1.1, flags: SJCL
  Incoming interface: Ethernet0/0, RPF nbr 192.168.101.10
  Outgoing interface list:
    Loopback0, Forward/Sparse, 02:26:30/00:02:00

(*, 224.0.1.40), 2d18h/00:02:51, RP 10.0.1.1, flags: SJPCL
  Incoming interface: Ethernet0/0, RPF nbr 192.168.101.10
  Outgoing interface list: Null

 

 

Outgoing interface flags: H - Hardware switched, A - Assert winner, p - PIM Join
 Timers: Uptime/Expires
 Interface state: Interface, Next-Hop or VCD, State/Mode

(*, 224.1.2.1), 00:00:05/stopped, RP 10.0.1.1, flags: SP
  Incoming interface: Ethernet0/1, RPF nbr 192.168.11.1
  Outgoing interface list: Null

(10.1.10.1, 224.1.2.1), 00:00:05/00:02:54, flags: T
  Incoming interface: Ethernet0/0, RPF nbr 192.168.101.11
  Outgoing interface list:
    Ethernet0/2, Forward/Sparse, 00:00:03/00:03:26

(*, 224.1.1.1), 00:06:52/00:02:09, RP 10.0.1.1, flags: SJCL
  Incoming interface: Ethernet0/1, RPF nbr 192.168.11.1
  Outgoing interface list:
    Loopback0, Forward/Sparse, 00:06:34/00:02:09
    Ethernet0/0, Forward/Sparse, 00:06:52/00:02:31

(*, 224.0.1.40), 2d16h/00:03:10, RP 10.0.1.1, flags: SJCL
  Incoming interface: Ethernet0/1, RPF nbr 192.168.11.1
  Outgoing interface list:
    Ethernet0/0, Forward/Sparse, 1d12h/00:03:10

PE1#    

 


//
(*,224.0.0.0/4) RPF nbr: 10.0.1.1 Flags: L C RPF P
  Up: 2d18h
  Outgoing Interface List
    Decapstunnel0 Flags: NS DI, Up: 2d18h

(*,224.0.0.0/24) Flags: D P
  Up: 2d18h

(*,224.0.1.39) Flags: S P
  Up: 2d18h

(*,224.0.1.40) Flags: S P
  Up: 2d18h
  Outgoing Interface List
    Loopback0 Flags: II LI, Up: 2d18h
    GigabitEthernet0/0/0/2 Flags: LI, Up: 2d16h

(*,224.1.1.1) RPF nbr: 10.0.1.1 Flags: C RPF
  Up: 00:07:08
  Incoming Interface List
    Decapstunnel0 Flags: A, Up: 00:07:08
  Outgoing Interface List
    GigabitEthernet0/0/0/0 Flags: F NS, Up: 00:07:08

(*,224.1.2.1) RPF nbr: 10.0.1.1 Flags: C RPF
  Up: 00:06:33
  Incoming Interface List
    Decapstunnel0 Flags: A, Up: 00:06:33
  Outgoing Interface List
    GigabitEthernet0/0/0/1 Flags: F NS, Up: 00:06:33

(10.1.10.1,224.1.2.1) RPF nbr: 10.0.1.1 Flags: L RPF
  Up: 00:00:21
  Incoming Interface List
    Decapstunnel0 Flags: A, Up: 00:00:17

(*,232.0.0.0/8) Flags: D P
  Up: 2d18h
RP/0/0/CPU0:P1_RR#                     


//


(*, 224.0.1.40), 2d16h/00:02:47, RP 10.0.1.1, flags: SJPCL
  Incoming interface: Ethernet0/0, RPF nbr 192.168.2.1
  Outgoing interface list: Null

P2_RR#


///

(*,224.0.0.0/4) RPF nbr: 192.168.21.1 Flags: C RPF P
  Up: 2d19h

(*,224.0.0.0/24) Flags: D P
  Up: 1w0d

(*,224.0.1.39) Flags: S P
  Up: 1w0d

(*,224.0.1.40) Flags: S P
  Up: 1w0d
  Outgoing Interface List
    Loopback0 Flags: II LI, Up: 2d16h
    GigabitEthernet0/0/0/0 Flags: LI, Up: 1d12h

(*,224.1.2.1) RPF nbr: 192.168.21.1 Flags: C RPF
  Up: 00:06:22
  Incoming Interface List
    GigabitEthernet0/0/0/3 Flags: A NS, Up: 00:06:22
  Outgoing Interface List
    Loopback0 Flags: F IC NS II LI, Up: 00:05:33
    GigabitEthernet0/0/0/0 Flags: F NS, Up: 00:06:22

(10.1.10.1,224.1.2.1) RPF nbr: 192.168.112.10 Flags: RPF
  Up: 00:00:09
  Incoming Interface List
    GigabitEthernet0/0/0/1 Flags: A, Up: 00:00:09
  Outgoing Interface List
    Loopback0 Flags: F IC NS, Up: 00:00:09
    GigabitEthernet0/0/0/0 Flags: F NS, Up: 00:00:09

(*,232.0.0.0/8) Flags: D P
  Up: 1w0d
RP/0/0/CPU0:PE2#                 


//
(*, 224.1.2.1), 00:06:27/stopped, RP 10.0.1.1, flags: SJCL
  Incoming interface: Ethernet0/0, RPF nbr 192.168.102.20
  Outgoing interface list:
    Loopback0, Forward/Sparse, 00:06:27/00:02:37

(10.1.10.1, 224.1.2.1), 00:00:14/00:02:45, flags: LJT
  Incoming interface: Ethernet0/0, RPF nbr 192.168.102.20
  Outgoing interface list:
    Loopback0, Forward/Sparse, 00:00:14/00:02:45

(*, 224.0.1.40), 2d16h/00:02:51, RP 10.0.1.1, flags: SJPCL
  Incoming interface: Ethernet0/0, RPF nbr 192.168.102.20
  Outgoing interface list: Null

CE2#    

 

###
Implement PIM-SSM

Use the ip igmp join-group source command under interface configuration mode to simulate SSM multicast receivers. On the Cisco IOS XR Software, use join-group source command under interface configuration mode under router igmp configuration mode.


On CE1:
CE1# show ip mroute
...
<some output may be ommitted>
...
Interface state: Interface, Next-Hop or VCD, State/Mode

(192.168.102.21, 224.1.1.1), 09:12:26/00:02:01, flags: sLTI
  Incoming interface: Ethernet0/0, RPF nbr 192.168.101.10
  Outgoing interface list:
    Loopback0, Forward/Sparse, 09:12:26/00:02:01

(*, 224.0.1.40), 3d15h/00:02:11, RP 10.0.1.1, flags: SJPCL
  Incoming interface: Ethernet0/0, RPF nbr 192.168.101.10
  Outgoing interface list: Null

CE1#   sh run int lo0
Building configuration...

Current configuration : 175 bytes
!
interface Loopback0
 ip address 10.1.10.1 255.255.255.255
 ip pim sparse-mode
 ip igmp join-group 224.1.1.1 source 192.168.102.21
 ipv6 address 2001:DB8:10:1:10::1/128
end

ip pim ssm range 1

access-list 1 permit 224.1.1.1

 

CE1#
 

 

 

 

 

########
Implement BIDIR-PIM
########

Bidir-PIM also has unconditional forwarding of source traffic toward the RP upstream on the shared tree, but no registering process for sources as in PIM-SM.
Forwarding of traffic in all routers solely based on the (*, G) multicast routing entries.
In bidir-PIM, the packet forwarding rules have been improved over PIM-SM, allowing traffic to be passed up the shared tree toward the RP. To avoid multicast packet looping, bidir-PIM introduces a new mechanism called designated forwarder (DF) election, which establishes a loop-free SPT rooted at the RP.
The procedure for joining the shared tree of a bidirectional group is almost identical to that used in PIM SM. One main difference is that, for bidirectional groups, the role of the DR is assumed by the DF for the RP.


http://www.cisco.com/c/dam/en/us/products/collateral/ios-nx-os-software/multicast-enterprise/prod_white_paper0900aecd80310db2.pdf

 

 

////////////////////////////////////////
Implement Rendezvous Point Distribution
////////////////////////////////////////
- On the pod PE router, disable both interfaces toward the core devices (P1 and P2 routers).
Neighbor        V           AS MsgRcvd MsgSent   TblVer  InQ OutQ Up/Down  State/PfxRcd
10.0.1.1        4        64500       0       0        1    0    0 00:00:05 Idle
10.0.2.1        4        64500       0       0        1    0    0 00:00:05 Idle
192.168.101.11  4        64501       5       2        1    0    0 00:00:05        2
PE1#


Neighbor        Spk    AS MsgRcvd MsgSent   TblVer  InQ OutQ  Up/Down  St/PfxRcd
10.0.1.1          0 64500   21677   21665        0    0    0 00:00:33 Idle
10.0.2.1          0 64500   23841   21665        0    0    0 00:00:33 Idle
192.168.102.21    0 64502   21992   19998       84    0    0 00:00:32          2
RP/0/0/CPU0:PE2#


On the pod CE and PE routers, make sure that IS-IS is enabled. On the pod CE router, shut down the BGP neighbor. Use the following NET addresses for IS-IS:
CEx 49.000x.0100.0x01.0001.00
CEy 49.000y.0100.0y01.0001.00


on CE1:
interface Loopback0
 ip address 10.1.10.1 255.255.255.255
 ip router isis
 ip pim sparse-mode
 ip igmp join-group 224.1.1.1
 ipv6 address 2001:DB8:10:1:10::1/128
end

 

router isis
 net 49.0001.0100.0101.0001.00
 is-type level-2-only


interface Ethernet0/0
 ip address 192.168.101.11 255.255.255.0
 ip router isis
 ip pim sparse-mode
 ipv6 address 2001:DB8:192:168:101::11/80
end

 

CE1#ping 10.2.10.1
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 10.2.10.1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 2/2/3 ms
CE1#

CE2#ping 10.1.10.1
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 10.1.10.1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 1/2/3 ms
CE2#


//

On the pod CE router, make sure that PIM-SM is enabled on the Loopback0 and first Gigabit Ethernet interfaces. On the pod PE router, make sure PIM-SM is enabled on the Loopback0 interface and first and second Gigabit Ethernet interfaces.

PE1:
ip pim send-rp-announce Loopback0 scope 10
ip pim send-rp-discovery Loopback0 scope 10
ip pim rp-candidate Loopback0

access-list 1 permit 224.1.1.1
access-list 1 permit 224.1.2.1


PE2:
router pim
 address-family ipv4
  auto-rp mapping-agent GigabitEthernet0/0/0/1 scope 10 interval 60
  auto-rp candidate-rp Loopback0 scope 10 group-list 224-4 interval 60
  interface Loopback0

 

Activity Verification:
RP/0/0/CPU0:PE2#show pim group-map
Wed Jul 29 16:08:32.734 UTC

IP PIM Group Mapping Table
(* indicates group mappings being used)
(+ indicates BSR group mappings active in MRIB)

Group Range         Proto Client   Groups RP address      Info

224.0.1.39/32*      DM    perm     1      0.0.0.0         
224.0.1.40/32*      DM    perm     1      0.0.0.0         
224.0.0.0/24*       NO    perm     0      0.0.0.0         
232.0.0.0/8*        SSM   config   0      0.0.0.0         
224.0.0.0/4*        SM    autorp   2      10.2.1.1        RPF: De0,10.2.1.1 (us)
224.0.0.0/4         SM    static   0      0.0.0.0         RPF: Null,0.0.0.0
RP/0/0/CPU0:PE2#


PE1#show ip pim rp mapping
PIM Group-to-RP Mappings
This system is an RP (Auto-RP)
This system is a candidate RP (v2)
This system is an RP-mapping agent (Loopback0)

Group(s) 224.0.0.0/4
  RP 10.2.1.1 (?), v2
    Info source: 10.2.1.1 (?), elected via Auto-RP
         Uptime: 1w4d, expires: 00:02:44
  RP 10.1.1.1 (?), v2v1
    Info source: 10.1.1.1 (?), via Auto-RP
         Uptime: 1w4d, expires: 00:02:04
PE1#  

 

CE1#show ip pim rp mapping
PIM Group-to-RP Mappings

Group(s) 224.0.0.0/4
  RP 10.2.1.1 (?), v2
    Info source: 10.1.1.1 (?), elected via Auto-RP
         Uptime: 1w4d, expires: 00:02:08
CE1#

 

CE2#show ip pim rp mapp
PIM Group-to-RP Mappings

Group(s) 224.0.0.0/4
  RP 10.2.1.1 (?), v2
    Info source: 10.1.1.1 (?), elected via Auto-RP
         Uptime: 00:06:05, expires: 00:02:57
CE2#

 


////////////////////////////////////////
TASK: Enable BSR
////////////////////////////////////////

Before you continue with the verification, clear group-to-RP mapping table on the pod CE and PE router. The clear ip pim rp-mapping command should be entered on the Cisco IOS/IOS XE router and the clear pim autorp command should be entered on the Cisco IOS XR router.

PE2:
On the pod PE router, use the Loopback0 interface to configure a BSR candidate and BSR RP candidate.
RP/0/0/CPU0:PE2(config)#router pim
RP/0/0/CPU0:PE2(config-pim)#bsr ?
  candidate-bsr  configure candidate BSR
  candidate-rp   BSR Candidate RP Configurations
  relay          BSR RP relay config
RP/0/0/CPU0:PE2(config-pim)#bsr candidate-bsr ?
  A.B.C.D  IP address of configured BSR
RP/0/0/CPU0:PE2(config-pim)#bsr candidate-bsr 10.2.1.1
RP/0/0/CPU0:PE2(config-pim)#bsr candidate-bsr 10.2.1.1 ?
  hash-mask-len  BSR Hash Mask Length
  priority       BSR Priority
  <cr>           
RP/0/0/CPU0:PE2(config-pim)#bsr candidate-bsr 10.2.1.1
RP/0/0/CPU0:PE2(config-pim)#commi
Wed Jul 29 16:39:50.146 UTC
RP/0/0/CPU0:PE2(config-pim)#bsr candidate-rp ?         
  A.B.C.D  IP address of BSR Candidate-RP
RP/0/0/CPU0:PE2(config-pim)#bsr candidate-rp 10.2.1.1
RP/0/0/CPU0:PE2(config-pim)#commi
Wed Jul 29 16:40:06.184 UTC
RP/0/0/CPU0:PE2(config-pim)#exit
RP/0/0/CPU0:PE2(config)#exit
RP/0/0/CPU0:PE2#


PE1:

PE1(config)#ip pim bsr-candidate loopback 0
PE1(config)#ip pim rp-candidate loopback 0
PE1(config)#
*Jul 29 20:41:03.854: %LINEPROTO-5-UPDOWN: Line protocol on Interface Tunnel2, changed state to up
*Jul 29 20:41:03.861: %LINEPROTO-5-UPDOWN: Line protocol on Interface Tunnel3, changed state to up
PE1(config)#exit

 

CE1:
CE1#show ip pim rp mapping
PIM Group-to-RP Mappings

CE1#
*Jul 29 20:40:24.344: %LINEPROTO-5-UPDOWN: Line protocol on Interface Tunnel0, changed state to up
CE1#show ip pim rp mapping
PIM Group-to-RP Mappings

Group(s) 224.0.0.0/4
  RP 10.2.1.1 (?), v2
    Info source: 10.2.1.1 (?), via bootstrap, priority 192, holdtime 150
         Uptime: 00:00:07, expires: 00:02:18
CE1#
CE1#
CE1#
*Jul 29 20:41:03.849: %LINEPROTO-5-UPDOWN: Line protocol on Interface Tunnel1, changed state to up
CE1#show ip pim rp mapping
PIM Group-to-RP Mappings

Group(s) 224.0.0.0/4
  RP 10.1.1.1 (?), v2
    Info source: 10.2.1.1 (?), via bootstrap, priority 0, holdtime 150
         Uptime: 00:00:04, expires: 00:02:21
  RP 10.2.1.1 (?), v2
    Info source: 10.2.1.1 (?), via bootstrap, priority 192, holdtime 150
         Uptime: 00:00:44, expires: 00:02:23
CE1#
CE1#


CE2#show ip pim rp mapping
PIM Group-to-RP Mappings

CE2#
*Jul 29 20:40:24.346: %LINEPROTO-5-UPDOWN: Line protocol on Interface Tunnel0, changed state to up
CE2#show ip pim rp mapping
PIM Group-to-RP Mappings

Group(s) 224.0.0.0/4
  RP 10.2.1.1 (?), v2
    Info source: 10.2.1.1 (?), via bootstrap, priority 192, holdtime 150
         Uptime: 00:00:12, expires: 00:02:15
CE2#
*Jul 29 20:41:03.844: %LINEPROTO-5-UPDOWN: Line protocol on Interface Tunnel1, changed state to up
CE2# sh ip pim rp mapp
CE2# sh ip pim rp mapping
PIM Group-to-RP Mappings

Group(s) 224.0.0.0/4
  RP 10.1.1.1 (?), v2
    Info source: 10.2.1.1 (?), via bootstrap, priority 0, holdtime 150
         Uptime: 00:02:20, expires: 00:02:27
  RP 10.2.1.1 (?), v2
    Info source: 10.2.1.1 (?), via bootstrap, priority 192, holdtime 150
         Uptime: 00:02:59, expires: 00:02:26
CE2#

 

 

////////////////////////////////////////
TASK: Enable Anycast RP
////////////////////////////////////////

On the pod PE router, remove the BSR candidate and BSR RP candidate configuration:
PE1(config)#no ip pim bsr-candidate Loopback0 0
PE1(config)#no ip pim rp-candidate Loopback0

RP/0/0/CPU0:PE2(config-pim)# no bsr candidate-rp 10.2.1.1
RP/0/0/CPU0:PE2(config-pim)#no bsr candidate-bsr 10.2.1.1

 

On the pod PE router, enable the Loopback1 interface and assign IP address 1.1.1.1/32. Make sure that the Loopback1 subnet is announced to the pod CE router via the IS-IS routing protocol. On the newly configured Loopback1 interface, enable PIM-SM:

RP/0/0/CPU0:PE2(config)#interface loopback 1
RP/0/0/CPU0:PE2(config-if)# ipv4 address 1.1.1.1/32

RP/0/0/CPU0:PE2(config)#router isis 1
RP/0/0/CPU0:PE2(config-isis)#interface loopback 1
RP/0/0/CPU0:PE2(config-isis-if)#address-family ipv4


RP/0/0/CPU0:PE2(config-pim)#ipv4 rp-address 1.1.1.1
RP/0/0/CPU0:PE2(config-pim)#commit


Between the pod PE and neighbor pod PE routers, establish MSDP adjacency. Use the PE router Loopback0 IP address as the source address of MSDP packets and as the originator ID:

PE1(config)#ip msdp peer 10.2.1.1 connect-source loopback 0 ?
  remote-as  Configured AS number
  <cr>
PE1(config)#ip msdp peer 10.2.1.1 connect-source loopback 0
PE1(config)#exit


RP/0/0/CPU0:PE2(config)#router msdp
RP/0/0/CPU0:PE2(config-msdp)#connect-source loopback 0
RP/0/0/CPU0:PE2(config-msdp)#  peer 10.1.1.1

 

Verification:
PE1#sh ip msdp summary
MSDP Peer Status Summary
Peer Address     AS    State    Uptime/  Reset SA    Peer Name
                                Downtime Count Count
10.2.1.1         ?     Up       00:00:22 0     0     ?
PE1#


RP/0/0/CPU0:PE2#sh msdp summary
Wed Jul 29 17:24:42.881 UTC
Out of Resource Handling Enabled
Maximum External SA's Global : 20000
Current External Active SAs : 0

MSDP Peer Status Summary
 Peer Address    AS           State    Uptime/   Reset Peer    Active Cfg.Max   TLV
                                       Downtime  Count Name    SA Cnt Ext.SAs recv/sent
 10.1.1.1        0            Up       00:00:47  0     ?        0      0        1/2
RP/0/0/CPU0:PE2# sh msdp peer ?
  Hostname or A.B.C.D  Peer name or address
  |                    Output Modifiers
  <cr>                 
RP/0/0/CPU0:PE2# sh msdp peer 10.1.1.1
Wed Jul 29 17:24:49.731 UTC
MSDP Peer 10.1.1.1 (?), AS 0
Description:
  Connection status:
    State: Up, Resets: 0, Connection Source: 10.2.1.1
    Uptime(Downtime): 00:00:54, SA messages received: 0
    TLV messages sent/received: 2/1
  Output messages discarded: 0
    Connection and counters cleared 00:00:54 ago
  SA Filtering:
    Input (S,G) filter: none
    Input RP filter: none
    Output (S,G) filter: none
    Output RP filter: none
  SA-Requests:
    Input filter: none
    Sending SA-Requests to peer: disabled
  Password: None
  Peer ttl threshold: 2
  Input queue size: 0, Output queue size: 0
  KeepAlive timer period: 30
  Peer Timeout timer period: 75
  NSR:
    State: Unknown, Oper-Downs: 0
    NSR-Uptime(NSR-Downtime): 3w6d

RP/0/0/CPU0:PE2#

CE2# ping 224.1.2.1 repeat 10
Type escape sequence to abort.
Sending 10, 100-byte ICMP Echos to 224.1.2.1, timeout is 2 seconds:

Reply to request 0 from 10.2.1.1, 4 ms
Reply to request 0 from 10.2.10.1, 24 ms
Reply to request 0 from 10.2.10.1, 24 ms
Reply to request 1 from 10.2.1.1, 6 ms

 

RP/0/0/CPU0:PE2#show  msdp sa-cache
Wed Jul 29 17:27:31.050 UTC

MSDP Flags:
E - set MRIB E flag , L - domain local source is active,
EA - externally active source, PI - PIM is interested in the group,
DE - SAs have been denied.  Timers age/expiration,
Cache Entry:
(192.168.102.21, 224.1.1.1), RP 1.1.1.1, MBGP/AS 0, 00:01:21/local
  Learned from peer local, RPF peer local
  SAs recvd 0, Encapsulated data received: 0
    grp flags: none,  src flags: L
(10.2.10.1, 224.1.1.1), RP 1.1.1.1, MBGP/AS 0, 00:01:21/local
  Learned from peer local, RPF peer local
  SAs recvd 0, Encapsulated data received: 0
    grp flags: none,  src flags: L
(192.168.102.21, 224.1.2.1), RP 1.1.1.1, MBGP/AS 0, 00:00:06/local
  Learned from peer local, RPF peer local
  SAs recvd 0, Encapsulated data received: 0
    grp flags: PI,  src flags: L
(10.2.10.1, 224.1.2.1), RP 1.1.1.1, MBGP/AS 0, 00:00:06/local
  Learned from peer local, RPF peer local
  SAs recvd 0, Encapsulated data received: 0
    grp flags: PI,  src flags: L
RP/0/0/CPU0:PE2#